Краткий обзор

TagScanner 5.0 сборка 508

Мощная программа для организации и управления музыкальными архивами. TagScanner переименовывает музыкальные файлы различных форматов так, чтобы в их имени содержалась информация из тэгов. Также программа позволяет сгенерировать тэг по имени файла/папки, или изменить значения необходимых полей в пакетном режиме. Программа имеет широкие возможности для получения информации об альбоме через интернет базу данных freedb.org. Поддерживаются теги ID3v1 и ID3v2, Vorbis Comments и APEv2, тэги WindowsMedia и MP4 (iTunes).
Универсальный редактор ТЭГов поможет быстро и удобно обработать необходимую информацию, в том числе в пакетном режиме. Также имеется в наличии простой, но удобный редактор плейлистов, позволяющий сохранять и читать листы в PLS/M3U и экспортировать их в HTML и таблицы Excel. Программа в большинстве случаев значительно облегчает жизнь, когда требуется привести в порядок свой музыкальный архив.

Главные особенности

  • Переименование музыкальных файлов по информации из тэгов
  • Мощный Р едактор тэгов, поддерживающий одновременную обработку множества файлов.
  • Генерация тэгов по информации из интернет (freedb)
  • Ручной текстовый поиск информации в freedb
  • Генерация тэгов по имени файла/папки
  • Замена слов и замена регистра тэгов и имен файлов
  • Полная поддержка Unicode
  • Работа с файлами MP3, OGG, Musepack, Monkey’s Audio, FLAC, AAC, OptimFROG, SPEEX, WavePack, TrueAudio, WMA, MP4.
  • Поддержка ID3 тэгов версий 1.0/1.1/2.2/2.3/2.4, APE v1 и v2, Vorbis Comments, WMA тэгов и метаданных MP4(iTunes)
  • Чтение и запись ID3v2 лирики и графики
  • Преобразование версий тэгов
  • Редактор плейлистов
  • Запись дополнительной информации в плейлист как у Winamp'а или Sonique
  • Экспорт плейлистов в HTML, Excel и CSV(удобно для баз данных, напр. MySQL)
  • Встроенный много-форматный плеер

    • Перевод файла Помощи: Trans-Master trans-master@list.ru

    (c) 1999-2006 Sergey Serkov


Основная информация

Загружайте аудио-файлы в программу - кнопкой [image] Обзор... (Browse...), или введите вручную путь к файлу. Если программа находит хотя бы один поддерживаемый файл, Вы увидите его в окне программы. Если Вы хотите отображать файлы в подпапках, пожалуйста отметьте в диалоге обзора папок опцию [image] Искать в подпапках (Search subfolders).

Теперь выберите файл(ы), который Вы хотите обработать, используя мышь или клавиатуру и переключитесь на необходимый Вам, функциональный модуль.

Используя Контекстное меню, Вы можете Копировать/Перемещать/Удалять выбранные файлы и делать дополнительную операцию с тэгами, то есть переименовывать папку, содержащую выбранный файл, используя выбранную строку тэга.

Дважды щелкните на файле, чтобы прослушать его. Дважды щелкните на заголовке группы, чтобы выделить все файлы в этой группе.

Для получения подробной информации - см информацию по использованию модулей:

Средство переименования аудио-файлов (Music renamer) | - Переименовывает аудио-файлы, используя информацию из тэга
Редактор тэгов (TAG editor) | - Редактирует тэги и лирику
Генератор тегов (TAG Processor) | - Пакетная обработка Тэгов и доступ к freedb
Редактор плей-листов(LIST maker) | - Создаёт и редактирует Плей-листы


Информация о Тэгах

Программа поддерживает тэги ID3 1.0/1.1/2.2/2.3/2.4, тэги APE v1 и v2, Vorbis Comments, тэги WMA и метаданные MP4(iTunes). Некоторые аудио-файлы могут иметь одновременно несколько тэгов.

Таблица соотношений форматов файлов и тэгов:
Формат файла/тэга | Чтение | Изменение | Изменение(Авто)
Advanced Audio Coding AAC | ID3v1, ID3v2, APEv1, APEv2 | ID3v1, ID3v2, APEv2 | ID3v1, APEv2
Monkey's Audio APE,MAC | ID3v1, ID3v2, APEv1, APEv2 | ID3v1, ID3v2, APEv2 | ID3v1, APEv2
Free Lossless Audio Codec FLAC | Vorbis Comments | Vorbis Comments | Vorbis Comments
MPEG Audio MP1,MP2,MP3 | ID3v1, ID3v2, APEv1, APEv2 | ID3v1, ID3v2, APEv2 | ID3v1, ID3v2
MPEG-4 MP4,M4A,M4B | метаданные MP4/iTunes | метаданные MP4/iTunes | метаданные MP4/iTunes
Musepack MPC,MPP,MP+ | ID3v1, ID3v2, APEv1, APEv2 | ID3v1, ID3v2, APEv2 | ID3v1, APEv2
Ogg Vorbis OGG | Vorbis Comments | Vorbis Comments | Vorbis Comments
OptimFROG(DualStream) OFR,OFS | ID3v1, ID3v2, APEv1, APEv2 | ID3v1, ID3v2, APEv2 | ID3v1, APEv2
Speex SPX | Vorbis Comments | Vorbis Comments | Vorbis Comments
True Audio TTA | ID3v1, ID3v2, APEv1, APEv2 | ID3v1, ID3v2, APEv2 | ID3v1, ID3v2
Windows Media Audio WMA, ASF | метаданные WindowsMedia | метаданные WindowsMedia | метаданные WindowsMedia
WavPack WV | ID3v1, ID3v2, APEv1, APEv2 | ID3v1, ID3v2, APEv2 | ID3v1, APEv2

Автоматический режим использует форматы тэга, рекомендованные разработчиками медиа-формата.

Начиная с версии 4.9, TagScanner полностью поддерживает Unicode (данные тэгов, имена файлов) на системах Windows NT/2000/xp/2003 и выше. Все стандарты тэгов, кроме ID3v1, ID3v2 и APEv1 - всегда сохраняют данные в Unicode. ID3v1 и APEv1 тэги не поддерживают Unicode вообще, а ID3v2 тэги могут произвольно сохранять данные в Unicode (Всегда ВКЛ по умолчанию). Если Вы пользуетесь программами, переносными или автомобильными аудио-устройствами, которые имеют проблемы с тэгами ID3v2, сохраненными в Unicode, - просто в [image] Глобальных настройках Программы выберите Никогда(Never), для опции Сохранения ID3v2 в Unicode.

Программа никогда не удаляет никакие неопознанные или неиспользуемые поля тэгов.

ID3v2 тэг хранится в начале файла, именно поэтому уходит большое количество времени, чтобы записать его (программе нужно перемещать все данные файла). Файлы OGG, WMA, MP4 создаются заново, именно поэтому всегда уходит большое количество времени, чтобы записать их.


Средство переименования файлов(Music renamer)

Используя этот модуль Вы можете переименовать файлы, основываясь на тэге и информации о файле.

Этот модуль использует параметры настройки Чтения, чтобы прочитать выбранный формат тэга из много-тэговых файлов (например MP3).

Чтение
ID3v1 | используется только ID3v1
ID3v2 | если имеется тэг ID3v2, то используется это значение, а так же используется значение из тэга ID3v1
APE | программа сначала читает ID3v1 тэг, после этого ID3v2 тэг и после этого тэг APE

Строка Формат(Format) определяет схему создания имени файла, при операции переименования. Строка Формат состоит из любых символов и предопределенных подстановочных значений. Каждое подстановочное значение начинается со знака процента (%). Подстановочные значения в этой строке будут заменены информацией из файла, когда Вы выполняете операцию переименования.

Вы можете использовать наклонную черту влево '\', для создания папок. Корневым каталогом для этой операции будет служить папка, содержащая файл. Эта функция очень пригодится для упорядочивания Ваших альбомов.

Выберите файл(ы) для переименования, используя мышь или клавиатуру. Нажмите кнопку Переименовать(Rename) и наслаждайтесь результатом, или нажмите кнопку Проба(Preview) чтобы убедиться, что ваши новые имена файлов - будут изменены так, как Вы хотите.


Редактор тэгов (TAG editor)

Используя этот модуль, Вы можете создавать новые и редактировать существующие тэги.

Этот модуль использует параметры настройки Чтения, чтобы прочитать выбранный формат тэга из много-тэговых файлов и параметры настройки Записи, чтобы записать выбранные форматы тэга в много-тэговые файлы.

Чтение
ID3v1 | используется только ID3v1
ID3v2 | если имеется тэг ID3v2, то используется это значение, а так же используется значение из тэга ID3v1
APE | программа сначала читает ID3v1 тэг, после этого ID3v2 тэг и после этого тэг APE
Запись
ID3v1 | Сохраняются только ID3v1 тэги
ID3v2 | Сохраняются только ID3v2 тэги
APEv2 | Сохраняются только APEv2 тэги
ID3v1+ID3v2 | Записываются ID3v1 + ID3v2 тэги
APEv2+ID3v1 | Записываются APEv2 + ID3v1 тэги
Все сразу | Записываются все тэги сразу
Auto | Тэги записываются, основываясь на формате потока

TagScanner указывает версию и тип тэга для текущего файла.

Выберите файл(ы) для редактирования, используя мышь или клавиатуру. Тэг выбранного файла(ов) будет показан в полях для ввода, в правой части окна.

Введите информацию тэга в поля для ввода. Если одно из полей содержит текст '< varied/unchanged >', программа сохранит текущее содержание этого поля тэга при сохранении нового тэга.

Нажмите на название поля тэга, чтобы блокировать информацию этого тэга - это поле не будет изменяться при выборе другого файла. Если Вы блокируете поле Трек(Track), то значение номера трека будет увеличено на один, при выборе другого файла.

Нажмите кнопку Удалить(Remove), чтобы удалить тэги из выбранных файлов.

Нажмите кнопку Сохранить(Save), чтобы сохранить новые тэги в выбранные файлы.


Редактор плей-листов(List maker)

Используя этот модуль, Вы можете создавать новые и редактировать существующее плей-листы.

Этот модуль использует параметры настройки Чтения, чтобы прочитать выбранный формат тэга из много-тэговых файлов (то есть MP3).

Чтение
ID3v1 | используется только ID3v1
ID3v2 | если имеется тэг ID3v2, то используется это значение, а так же используется значение из тэга ID3v1
APE | программа сначала читает ID3v1 тэг, после этого ID3v2 тэг и после этого тэг APE

Программа читает информацию тэга только один раз и не перечитывает эту информацию при переключении режимов работы с тэгами.

Экспортируйте плей-лист в HTML или Excel с расширенной информацией. Просто отметьте необходимые поля и нажмите Экспорт (Export).
Вы можете экспортировать плей-лист в формат CSV (ЗНАЧЕНИЯ, РАЗДЕЛЯЕМЫЕ ЗАПЯТОЙ). Это удобно для работы с базами данных (Access, MySQL).


Комбинации "горячих клавиш"

F1 - помощь по программе
Ctrl + R - Переименование файлов
Ctrl + G - Генерация тэгов
Ctrl + B - Открывает диалог Обзора папки с MP3
Ctrl + S - Сохранение тэга (TAG editor)
Ctrl + F1 - Открывает средство переименования MP3 (Music renamer)
Ctrl + F2 - Открывает Редактор тэгов (TAG editor)
Ctrl + F3 - Открывает Генератор тэгов (TAG processor)
Ctrl + F4 - Открывает Создатель Плей-листов (List maker)


Лицензия

TagScanner предоставляется как СВОБОДНО РАСПРОСТРАНЯЕМОЕ ПРОГРАМНОЕ ОБЕСПЕЧЕНИЕ для некоммерческого использования (дома).
TagScanner может быть свободно распространен с исключениями, отмеченными ниже. Предоставленный пакет не изменять.

ПРОГРАММА РАСПРОСТРАНЯЕТСЯ "КАК ЕСТЬ". НИКАКАЯ ГАРАНТИЯ ЛЮБОГО ВИДА НЕ ВЫРАЖЕНА И НЕ ПОДРАЗУМЕВАЕТСЯ. ВЫ ИСПОЛЬЗУЕТЕ ПРОГРАММУ НА ВАШ СОБСТВЕННЫЙ РИСК. АВТОР НЕ НЕСЁТ ОТВЕТСТВЕННОСТЬ за ПОТЕРЮ ДАННЫХ, УБЫТКИ, ПОТЕРЮ ПРИБЫЛИ ИЛИ ПОТЕРИ ЛЮБОГО ДРУГОГО ВИДА, ПРИ ИСПОЛЬЗОВАНИИ ИЛИ НЕПРАВИЛЬНОМ ИСПОЛЬЗОВАНИИ ЭТОЙ ПРОГРАММЫ.

(c) 1999-2005 Sergey Serkov


Системные требования

  • Windows NT4/2000/XP/2003/Vista
  • 5MВ на диске
  • Соединение с Интернет, для использования online-возможностей программы.

            •


История изменений

5.0 build 508 (11/12/2006)
* Improved : Now freedb2.org base used for manual search of album info
* Improved : Now you can use http://freedb2.org as web source (see options)
* Fix: Some graphic problems
* Translations: Dutch
5.0 build 507 (10/05/2006)
* Improved: ID3v2 embedded artwork processing for multi-tagged files
* Improved: Embedded artwork decoding speed increased for PNG
* Fix: Flac format support for some files
* Fix: Some translations problems
* Fix: Some tags are not saved from freedb request
5.0 build 506 (08/29/2006)
* Improved: MP4 'gnre' atom support
* Improved: Freedb: Impoved usability of change encoding function
* Improved: Changed look of renaming report
* Improved: Remember window state on exit
* Fix: ID3v2: Embedded artwork removed after updating tag info for multiple files
* Fix: Incorrect sortings in main filelist
* Translations: Turkish, Japanese
5.0 build 505 (08/05/2006)
* Interface redesigned
* New: Grouping in filelist
* New: One filelist for most operations
* New: Now user can perform per file operation instead of whole filelist
* New: Text processing module: text replacement, case change etc.
* New: Open files parent folder from context menu
* New: Option for scan last active folder on startup
* New: Option for preserve file modification time when saving tags
* New: Get tags from cue-files
* New: Renamer : Powerfull module for restructure files on disk based on tag information
* New: Renamer : Now you can autorename support files with same names ( *.cdg, *.txt default)
* New mediaformat: WindowsMedia (asf,wma) - stream info and metadata reading/saving
* New mediaformat: Mpeg4 (m4a,mp4 etc) - stream info and metadata reading/saving (iTunes format)
* Improved: Filelist: Additional columns
* Improved: Filelist: Changed logic for some sorting
* Improved: Showing filesize in KB, MB and so on
* Improved: Completely rewritten Vorbis tagging module
* Improved: Completely rewritten APE tagging module
* Improved: Special settings for writing ID3v2 tags in unicode format
* Improved: Editor : ID3V2 unicode flag indication
* Improved: Editor : Now can decode and show embedded PNG artwork
* Improved: Editor : New tag fields - BPM, Disk Number, Content Group Description, Part of Compilation (ID3v2, MP4 only)
* Improved: Listmaker: HTML-export: now save files in UTF8 encoding
* Improved: Listmaker: HTML-export: now use field names from language files
* Improved: Freedb: Updated search engine
* Improved: Freedb: Reworked UTF8 support
* Improved: Freedb: Codepage conversion for nonunicode results
* Improved: Renamer: Now you can set variable length of filename
* Improved: Renamer: Additional visualisations
* Improved: Renamer: New placeholder %8 for Disk number
* Improved: Slightly increased scan speed for non-mpeg based formats
* Improved: Removed some redundant scans
* Improved: Now you can cancel some longtime operations
* Improved: Player now supports Musepack, Mpeg4, Monkey’s Audio, FLAC, AAC, ALAC(Apple Lossless), OptimFROG, SPEEX, WavePack, TrueAudio files (Windows Media Format modules v9 or above are required for playback)
* Fix: Incorrect displaying and saving custom genres in unicode
* Fix: Sometimes tags are not saved for FLAC files
* Fix: Incorrect ID3v2.4 tag reading in some cases
* Fix: ID3v2.2 Album and Artist misplaced
* Fix: Incorrect text transcoding in non-affected frames from ID3v2
* Fix: Can't remove vorbis tag from flac files larger than 2GB
* Fix: Tags readed twice then you navigate in filelist with keyboard
* Fix: Program can't delete temporary file after creation of new ID3v2 tag for unicode-named files
* Fix: Player time displaying for long songs
* Fix: Ignored unicode paths as startup parameter string
* Fix: Filename -> TAG: Incorrect processing of unicode strings
* Fix: Filename -> TAG: Up one level folder name processing
* Fix: Filename -> TAG: Incorrect parsing of foldernames in some cases
* Fix: Listmaker: pls format export
* Fix: Trim filenames for *.wv files
* Updated support for some audioformats
* Optimized structure of language files
* Discontinued support for win9x family
* Revisited help
* Updated translations: Polish, Greek, Spanish, Turkish, Russian
* A lot of minor changes and fixes
4.9 build 497b (04/18/2005)
* Fix: pictures removed from ID3v2 in some cases
* Fix: sometimes Year field not recognized from ID3v2.4
* Translation: Chinese Simplified
4.9 build 497a (04/09/2005)
* Fix: ID3v2 incorrect work with TXXX frames
* Fix: Program freez on some mp3-files with APE-tags
* Fix: APEv2 tag incorrect saved in some cases
* Fix: Again! Preserve replaygain information in MP3 files
* Multichannel files recognition: WavPack, OGG
* Improved support for ID3v2 tags created by iTunes
4.9 build 496 (03/28/2005)
* Support for extended Vorbis-comments fields
* Fix: Preserve replaygain information in OGG files
* Fix: Preserve replaygain information in MP3 files
* Fix: Pictures not saved to ID3v2 tags
* Fix: removed debug file creation on FLAC reading
* Fix: WavPack 4 support, now based on official specifications
4.9 build 495a (03/12/2005)
* Fixed: East Asian languages support
* Fix: APEtag in some cases detected as ID3v1
* Processor: Fixed case conversions
* Freedb settings moved to general settings window
* Added option for Id3v2 unicode mode (off by default)
* Some interface changes
4.9 build 494 (03/06/2005)
* New ID3v2 core library
* Improved handling of incorrect ID3v2 frames
* Now supports ID3v2.2
* Fixed reading of UTF8 encoded APE tags
* Fixed unicode filenames processing
* Now you can view/edit unicode tags
* Freedb protocol version 6 support (UTF8)
* New language: Korean
* Program no longer work on Win95
* Improved stability
4.9 build 493 (02/05/2005)
* Translations: Finnish, Swedish
* Now you can close program during scan procedure
* TagEditor: Some corrections in remove multiple tags procedure
* Greatly increased afterscan operations speed, upto 10 time faster
* Fixed memory leaks on scan
* Some corrections in OGG support
* Lot of minor changes/fixes!
4.9 build 492 (01/08/2005)
* NEW format: WavPack version 4, also added encoder mode detection
* NEW format: TrueAudio (TTA) - ID3v1, ID3v2, APEv2 tags (id3v1+v2 in Auto mode)
* Translations: Belarussian, Hungarian, Dutch, Serbian
* Freedb: Fixed "Access violation" on file selection
* TagEditor: Some corrections in save multiple tags procedure
* Fixed: In some cases program can't remove ID3v2 comment
* Now program select up one level folder if current path not exists
* Updated sound engine
* Lot of minor changes/fixes!
4.9 build 490 (10/24/2004)
* New TAGformat > APE 1.0 and 2.0 Tags : Basic fields + Copyright,Composer,WWWUSER,EncodedBY,OrigArtist, UnsyncedLyrics
* New audioformat > SPEEX : streaminfo, vorbis comments
* New audioformat > FLAC : streaminfo, vorbis comments (supports padding)
* New audioformat > WavePack : streaminfo, all tags support
* New audioformat > OptimFROG(DualStream) : streaminfo, all tags support
* New audioformat > MonkeyAudio : streaminfo, all tags support
* New audioformat > AAC : streaminfo, all tags support
* Multilanguage interface: Czech, Galician, Norwegian, Portuguese (Iberian),Bulgarian, Thai, Italian, German, Portuguese (Brazil), Spanish, Polish, French, Russian, English
* Support for Unicode filenames!
* Resizeble inteface
* Separate settings for TAG reading/saving
* Renamer: Fixed parsing of renaming format string
* Renamer: Some corrections in Translit operation
* Editor: New interface!
* Editor: Multiple files tag editor!
* Editor: Track field as any string
* Editor: Now show version of output tag
* Editor: Functions for files (from context menu)
* Editor: Track autonumbering (from context menu)
* Editor: Now can Cut/Copy/Paste TAGs from/to multiple files
* Editor: Fixed error with lock Picture field
* Editor: Some correction on folder renaming from menu
* Editor: Now you can open file in associated application from context menu
* Editor: Now you can rename file directly in filelist (context menu or F2)
* Editor: Player now recheck played file on list resort
* Editor: Empty string for ID3v1.track instead 0
* Editor: Reset checked fields on rescan
* Editor: Now can delete corrupted ID3v2 tags
* Processor: Fixed parsing of input fields formatstring on tag generation
* Processor: Generator > Some corrections in foldername parsing
* Processor: Generator > Parse foldername as well as filename
* Processor: now can generate different Tags at once
* Processor: Generator > Reset field values function
* Processor: FIX: ogg-comments not removed in Tag Processor
* Freedb: http access and improved speed
* Freedb: proxy support
* Freedb: Search in online database
* Freedb: Manual query for albums info
* Freedb: FIX: Program don't write Vorbis comments
* Freedb: ability to manual set order of tracks after getting info from database
* Freedb: getting active servers list in settings
* Freedb: support for multistring titles
* Listmaker: Corrected export settings saving
* Listmaker: new list
* Updated case change procedures: [Every First Up] and [Only first up]
* New search and scan procedures (speedup!)
* Improved TAB navigation
* New engine for Vorbis comments processing
* Now you can delete formats/paths from stored list
* Pathfield now reread only after click Rescan button(or Enter key) (like explorer address bar)
* Some corrections in Musepack/MPC support
* Renamed genre AlternRock to Alt. Rock
* Corrected some visual appearances
* New installer
* Updated help file
* A lot of minor changes and fixes
4.8 build 481 (12/03/2003)
Store path from pathbox for browsing dialog
Bugfix: program don't show numbers in ID3v2 genres
Bugfix: Access violation then tag removed
More stable work with corrupted files
Updated sound engine
4.8 build 480 (10/27/2003)
Get album info from internet database freedb.org
Program now not buzz on win98/ME when you try to choice Genre from list
Bugfix: ID3v2 Comment not changed after save
Corrected bug with ID3v2 when Comment field displayed incorrectly in other programs
Program now use new style browse for folder dialog on win2k/XP
Renamer: CD ISO/Joilet filenames length control
Renamer: Now show extended info on Preview
Listmaker: Export > Ability to change column order
Listmaker: Export > Counter
Support for windows2003
Some other changes
4.7 build 472 (08/03/2003)
Improved interface render speed on WinXP
Now files not rescaned on Preview operations
More accurate ID3v2 and OGG-info tags reading
Improved OGG-info tag reading/writing speed
A lot of minor changes and fixes
4.7 build 471 (01/08/2003)
Fixed interface bugs on WinXP
Fixed interface problems when StyleXP installed
Improved OGG writing speed
A lot of minor changes and fixes
4.7 build 470 (29.12.2002)
New tag reading engine
New scanning algorithm
Removed 'TAG preview', now program always scan files for TAG
New sound engine: excelent OGG and MP3 playback
Support for OGG files (Vorbis tag and stream info)
Support for MpegPlus files (added stream info)
Fixed some resource leaks
Fixed ID3v2 Comment reading for some MP3s (e.g. created with CDex)
Fixed #Track writing
Reanmer: New options for 'spaces'
Renamer: Improved Rename folder by TAG
Editor: Added new fields in ID3v2 mode
Editor: Ability to read/write total album tracks (e.g. 01/12)
Listmaker: Export > Preinstalled Excel it is not necessary any more
Listmaker: Export > Changed #Track writing
Listmaker: Export > Some changes in HTML links
Listmaker: Work with OGG and MPC files
Hint for player now show track time and song info
Returned incremental search in lists
Greatly improved Unicode support in ID3v2
4.5 build 456 (20.08.2002)
Program now support MPEGplus files (Only ID3v1 and ID3v2 TAGs, no stream info)
Added support for graphics inside ID3v2 (JPEG,GIF,BMP)
Renamer: Subfolders creation by ID3
Editor: Correct lyrics writing/reading
Editor: New listfile sorting order (Artist - Title)
Editor: Ability to save/load lyrics to/from external file
Editor: Some functions for fields
TAGer: New special delimiter '_-_'
Listmaker: Some correction in Excel export
Listmaker: Comment and Track field in export settings
Listmaker: HTML export: active links to files
Listmaker: Added sort by Genre ability
Corrected genre - Trash metal to Thrash metal
Improved non-English TAGs support
Updated help files
4.5 build 454 (16.04.2002)
TAG Generator replaced with Batch TAGer for better mass TAG processing
TAGer features: Generate TAGs by filename/foldername or mass change any TAG fields
TAGer features: Copying TAGs between versions
TAGer features: Remove TAGs by version
TAGer: TAG fields capitalization
TAGer: Track value correction if not integer
TAGer: ID3v1: fixed bug with spaces in some fields after first time creation
Editor: Added support for Unsynchronised Lyrics
Editor: Save or Remove both TAG versions simultaneously
Editor: Improved tag switching operation
Editor: Little improved ID3v2 write speed
Listmaker: added export settings
Listmaker: added export to CSV (Comma Separated Values) format for databases
Listmaker: corrected track in album
Listmaker: files moving in list
Added support for ID3v2 compressed Tags
Better exceptions processing
Some language corrections
Ability to rescan folder
Fix to ID3v2 Unicode support
Fixed the resource leaks in scan operations
Fixed bug with reading some national characters (255ascii symbol)
Fixed bug with processing after moving or deleting files
Help file
4.5 build 452 (22.01.2002)
Support for ID3v2: version 2.3 / 2.4
Added 2 ID3 modes: ID3v1 - old mode / ID3v2 - combined (see Using)
Speedup all basic functions
Improvements in searching and scanning
Some interface improvements
For longtime operation added progress indicator in status bar
Editor: Rename file folders by ID3 (RightClick in filelist)
Editor: Operations with files (RightClick in filelist: Copy/Move/Delete)
Editor: Highlight now playing track
Editor: Some list sorting ability
Generator: Ability to Preview results
Generator: Changed 'Update' mode - now not empty fields has changed
Listmaker: HTML export: optimising by size
Listmaker: HTML export: CSS in HTML header
Listmaker: Excel export: columns headers
Listmaker: Ability to create playlists from any number of CD's
Listmaker: M3U playlist space bug
Listmaker: New sorting order: Track in Album
Renamer: New %N worksheet for old fileName
Browse dialog now store last folder
Command line parametr (use Foldername or Filename)
Work on CD-RW UDF disks (ability to saving)
Support for WinXP
Mpeg stream information fix
Correct processing files with ReadOnly attribute where possible(bug: Can't open file)
Correct translit (bug with 'a')
Correct Genres
Correct Genre generating
Correct time displaying
Correct size displaying
A lot of minor changes and fixes
4.3 build 437 (10.06.2001)
More stability on Windows2000
Bug fix: Double serching on click to [Recurse subdirectories]
Bug fix: Ctrl+R not work properly
Song information on mouse move on player
List maker: export to Excel (required installed Excel)
MP3 renamer: Genre on end of filename bug fix
MP3 renamer: 'division by zero' on some nonstandard MP3s
TAG editor: settings for quick tag preview in filelist
4.2
Added TAG generator (Filename --> ID3 Tag)!!!
Added Hotkeys
Improved player
MP3 renamer: added new worksheets
MP3 renamer: worksheets store
MP3 renamer: changed algorithm
TAG editor: quick tag view in filelist
A few other fixes I forgot to log
4.0 beta2
Added very quality player
Added test mode
MP3 renamer: translit for Cyrillic
MP3 renamer: added track number (%7)
List maker: right VBR detection
TAG editor: added more genres
TAG editor: added autosaving
TAG editor: fixed wrong sorting
Fixed a few small bugs
3.3
Added ability for work with subdirectories
MP3 renamer: fixed a bug with deleting some files
MP3 renamer: maximized rename speed
TAG editor: added output of extended information
List maker: added ability for write extended playlist to HTML
List maker: added ability for write extended playlists
List maker: maximized speed of scan/read/write
Fixed a few small bugs
3.0
Interface changed
MP3 renamer: added formating output
MP3 renamer: added spaces replacing
TAG editor: added simple surfing
TAG editor: added possibility for hold TAG editor positions
Added playlist editor (List maker)(undertesting)
2.0
Interface changed
Fixed progress indicator bug
Added TAG editor
1.1
Changed TAG scan algorithm
Fixed some stupid bugs
1.0
First release
top


Контактная информация

Автор TagScanner: Сергей Серков.

Домашняя страница программы:
http://xdev.narod.ru

Поддержка доступна только через электронную почту. Помните, что это - свободно распространяемая программа, поэтому я не могу удеять слишком много времени и усилий для неё. Я буду стараться отвечать на любую почту относящююся к этой программе. Пожалуйста, послайте автору свои сообщения об ошибках, комментирии и предложения. Языки для общения: английский язык, русский.
Если у Вас есть любые вопросы, комментарии или предложения о TagScanner или Вы хотели бы получить более подробную информацию, пишите:
xdev@narod.ru

(c) 1999-2005 Sergey Serkov